Project

General

Profile

Bug #19

Mouse Move can cause a game pause

Added by James Bryant 10 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Input (Mouse/Keyboard/Joystick)
Target version:
Start date:
05/11/2020
Due date:
% Done:

0%

Estimated time:

Description

This can be seen in the Sacrafice demo.

If I slow the rate of mouse moves to the program to 100 per second it works better, but this doesn't seem to be a good solution. If the emulation runs more slowly, like when in debug mode, then the problem just returns. Also holding down a keyboard key can also cause the same problem even if I disable key repeating. Sometimes after the pause the game will return to normal, other times it gets worse.

Associated revisions

Revision 1fcb467c (diff)
Added by James Bryant 9 months ago

#19 Added the ability to change the frequency of mouse and keyboard events sent to wine. The new command line argument is -pollRate. The default is 40 and 0 means unlimited like it was before this change. I also added the ability to set this option on a per app basis in the UI.

Revision b97636f1 (diff)
Added by James Bryant 6 months ago

#19 I think I finally fixed the mouse/keyboard issue that causes some games to hang. The fix came from studying in more detail winex11.drv/event.c/X11DRV_MsgWaitForMultipleObjectsEx

History

#1

Updated by James Bryant 9 months ago

  • Target version changed from Backlog to 20.1.X

I noticed that I can lag the menu screen in Quake 3 just by moving my mouse quickly. I believe this is caused by a high DPI mouse. There are a lot of reports of people having the problem with Wine under Linux and most of the solutions involve lowering the polling rate of the mouse. I may have not noticed this before. I only recently upgraded to a newer mouse and now that I know what to look for, I can see this happen in multiple games.

#2

Updated by James Bryant 9 months ago

I added the ability to set the polling frequency of mouse/keyboard events. This seems to fix Quake 3 for me. Sacrafice is a lot more stable, but it is rare to go more than 1 to 2 minutes into the game before seeing the freezes. The worst part is once the game starts to freeze it becomes a lot more likely to freeze. I've tried turning off key repeating and waiting for the event queue to be empty before adding more events. I've also tried setting the game to use a single thread. I even tried setting Wine to Windows 98. Nothing of things improved anything.

To reproduce this issue all you have to do is move the mouse around quickly while hitting keys on the keyboard.

#3

Updated by James Bryant 9 months ago

  • Target version changed from 20.1.X to Backlog
#4

Updated by James Bryant 4 months ago

  • Status changed from New to Closed

Also available in: Atom PDF